Subscribe via RSS
25Nov/210

NEC PC-9801VX – Tear-down

I've always been fascinated by the older Japanese beige desktops and couldn't resist another impulse-buy when I saw this PC-9801VX show up on eBay. It was cheap, as it was listed as junk, until the shipping cost doubled the price. Regardless, I took the gamble, as I have a copy of A-Train for the PC-98 that needs a home.

20211124 174537

It arrived quickly, as postage from Japan can only currently be done via expensive couriers. Before long it was plugged into the step-down converter and failed to do anything good. From what I understand, on power up these machines are meant to PI-PO from their internal speakers... Of which this one did not!

A quick tear down saw the cause... but more on that later. What was I thinking?; purchasing such a huge beige boxen of junk. Fortunately, the tear down also saw that it came with surprises! The list included: a 4MB o'RAM CBUS board, an 8MB o'RAM CBUS board, a SCSI CBUS board and a SASI CBUS board. Also, two 5 1/2" floppy drives which can't be scoffed at... if they work.

20211124 174737 20211124 174728 20211124 174708 20211124 174812

After a lot of research, it turns out that this unit is actually a 286, when purchased new. There's a lot of information online, but most of it is in Japanese. Fortunately, Wikipedia has a great article on the PC-98 series of machines and, if you scroll down far enough, you'll see this unit listed as an 80286 @ 8 or 10 MHz. BUT! What's that random sticker on the front?

20211125 095514

A 486, you say? In a 286 motherboard? I didn't quite believe it when I saw the photos on the auction... but opening it up showed that there was a slot for CPU upgrades and, well yes, you can actually put a myriad of faster CPUs in there! This one just happened to have a 486 upgrade.

20211125 095550

Nice. This opens up the game-play and MS Windows opportunities... if only I can get it to run.

Why wouldn't it boot?

Unfortunately, once down to the board, the CMOS battery proved to be the cause of failing to post. Excuse the awful photo, but I was in a state of buyer's remorse...

20211103 170605

You can see the green.. all the way into the CPU slot (middle-bottom) and, well, even further off the edges of the photo. The battery was quickly removed, but the damage was far-spread. Without schematics, tracing those corroded lines would be a nightmare. But what if I could find a replacement?

Buyee to the rescue

Turns out I had a cart of things to purchase from Japan, so I bit the bullet and purchased a junk spare motherboard for this machine. Yes, junk! That's all that was available online... no one in their right-mind would list these boards as 100% brand-new and ready-to-roll. I threw in a LAN card and a terribly-yellowed keyboard, just to double-down on my losses if everything failed! These also arrived in quick succession as Buyee charges like a wounded bull for shipping and uses top-notch couriers.

20211117 150338

The board was inspected and, to my surprise, was somehow perfectly clean. As above, you can see that the battery had corrosion, but it hadn't spread! Compared to the other board, it was a beautiful site.

20211123 215959

20211123 220027

Shit photo, I agree... but above you can see the difference of the areas under the battery. Top being the newly-acquired board, bottom being the one I may have half-attacked with isopropyl and a toothbrush. Maybe, now that I have a working board, I can trace everything on it and check on the old... but honeslty, even in 1986 these boards were so bloody complex that I don't believe I have the skills to re-trace all of those traces.

But does it work?

Everything was assembled hastily... First flick of the switch, nothing... crickets. After a re-seat of everything that could be re-seated, I flicked it again. During the re-seating, I'd also turned the front volume dial up to MAXXX and, on pressing the power a seriously neighbour-annoying PIIIII-POOO PAAAAAAAAAAAAAA was emitted... Of course, the glee of the first two notes was murdered when that last note came out, deafening and disturbing, lasting until I hit the power switch.

Third flick, after another re-seat... PI-PO! Shit, that sounded perfect... I just had nothing plugged in to any video outputs.

Making it output video

This vintage beast loves its archaic refresh rates (more info here). RGB is 15khz or possibly 24khz, but nothing a new monitor will approve of. This video card has three output ports and you'll find the pin-outs here. I hacked together a 5-pin DIN to RCA plug cable (same as the Megadrive, actually, just without sound) and hooked it from the video card's top Mono output port to my 4:3 Samsung LCD.

It worked! But the picture wasn't great... maybe this is NTSC? Probably. I re-installed my capture card and tested out VLC with correct NTSC_J settings.

pc-9801-memcheck pc-9801-basic-startpc-9801-scsi-bios

It @#$%#$$# works! That last shot is with the SCSI card in... so it's found the TEXACO BIOS (is that the oil company? where did this machine come from?!) and tried to enumerate SCSI devices. I had none for it... so I removed ALL CBUS cards and tried to boot my A-Train floppy...

pc-9801-floppy-boot-attempt

First drive found nothing, and when nothing is found the machine just boots into the BASIC prompt. After a reboot with the floppy in drive B, it produced the above and stalled. It actually sounded pretty bad... but diagnosing the floppy drives is a whole-nother post, of which I'll tackle later.

In the meantime, if you want to know more about these machines, check out NEC PC98 Basic Reference. The amount of information in there is amazing!

Filed under: Retro Leave a comment
Comments (0) Trackbacks (2)

No comments yet.


Leave a comment


*